Cannot change genre
Somehow I cannot change the genre in the Play app.

I can see all the genres in the dropdown box, and if I click on another one the name of the genre does change in the genre box in the bottom of the screen to the one I select. However, when I click on any of those buttons, for example Opposition, I get only things from the previous genre. In my case the genre is stuck on Zombie Apocalypse, so I only get zombies as opposition, but I want to do some Classic Fantasy now...

Mark, can you see where the problem is?

OK, I can reproduce this.
I took a look at the code and everything that uses a genre expects there to be just one story to get the genre from. Now that you can have multiple stories I need to go through and update all the code that uses the genre to pull it from the currently active story. I'll see if I can get this done this evening. Sorry for the inconvenience.
A lot of files got updated but some extra good came out of this; I thought of a way to speed up the site by a few milliseconds so I took the extra time and made some extra changes. So, maybe you'll see the speed increase.

Well, it's my bedtime now and I hope all is well.
Awesome! It works well for me. Thanks! You're the best!
I can't select a genre still, I get an error stating:

ErrorCode 2: No active story.

I've tried hitting save story button as well as going to story manager and typing a name under Add Story and click the Add Story button and nothing ever happens. I still end up with:

You have 1 Story Slots total with 0 Story Slots used.
Hi Mnbrightblade,

This is a strange little bug that rarely happens but for some reason got you this time. It seems your user settings were not being created. I'm still not sure why this happens to only some users but I made some changes that I think might help.

If you could log out of the forum, then log back in, then go to the Story Manager page and see if it works now I would appreciate it.

Thank you and sorry for the inconvenience.
Thank you for your quick response. It still doesn't work however.
I can't find what is preventing your settings from being created so I created them by hand and gave you an extra save slot.

Please try it now and let me know.
Still unable. Can I have my account deleted and start anew?

Forum Jump:

Users browsing this thread: 1 Guest(s)