Mark - my saves are disappearing!
OK, thank you for all the input. I was able to reproduce it by waiting a couple of hours and then doing a save. As Qavex said it does seem to be a timing thing.

I'm looking into it now.
I added a bunch of checks that, I believe, will ensure that if any information is not available due to some kind of long wait period or timeout, that the system should fetch the information needed in order to do a save. I've done some different kinds of testing and so far the fail-safes seem to be working.

I'm sorry for any frustration this may have caused and look forward to any feedback.
Thanks Mark.
Thanks Mark. Btw, last night I saved my Jodi ZA story, but just now, when I went to the Play link it had reverted back to an earlier save still. I closed down the site and reloaded made a change and clicked save and now it seems to be working.

Is there a trick to ensure it saves all the time?

Also, I'm wondering if maybe we can setup a log folder where it saves a copy of what we have at the moment we click Save from both the log and the sidebar pane into a simple txt file as a backup type thing. That'd be handy for times the server database has issues. Thanks for the work you do on the site.

(Enjoying my content? Want to show your support? Consider joining my Patreon at Roll, Ponder, and Play!)

OK, so there still seems to be an issue with a timeout somewhere that I must have missed. I'll see if I can find where the timeout is happening but also look into some kind of save redundancy mechanism.
Tracking this down has been tough but I think it's solved. I let a story sit for over an hour, did a save, refreshed the page, and the save stuck.
Just to be doubly sure I left a story open overnight then in the morning did a save, refreshed the page, and the save still worked. So I'm pretty confident the issue is resolved.
Thanks Mark. I'm glad to hear it! I've been scared to close down my tabs or refresh. Smile

(Enjoying my content? Want to show your support? Consider joining my Patreon at Roll, Ponder, and Play!)

Hello Mark,

I just experienced a similar situation with a disappearing save. It seems that my save was wiped. I was on earlier today, but ended up not adding anything to the story. I just logged in again now and the save is blank. I've tried reloading, resetting my comp, logging in/out. I'm pretty distraught that all the work is gone, I've been working on it for awhile and I was looking forward to posting it on the forum soon. Is there anyway way I can recover the save even if it is a older one?

Thank you for any help Mark.
Hi Impaala,

It looks like you have two stories in the database: MyStory and RT. You deleted MyStory and RT is empty.

Everything seems to be working and I cannot reproduce any data loss. Please note that what gets saved are the output where the results are displayed and your notes. The box where you type in text that gets sent to the display is not saved.

I will do some more testing and watch out for any similar issues.

Forum Jump:

Users browsing this thread: 1 Guest(s)